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User manual

Getting started with STM32CubeL4 MCU Package 
for STM32L4 Series and STM32L4+ Series

Introduction

STM32Cube is an STMicroelectronics original initiative to significantly improve designer's 
productivity by reducing development effort, time and cost. STM32Cube covers the whole 
STM32 portfolio. STM32Cube includes:

• A set of user-friendly software development tools to cover project development from 
the conception to the realization, among which are:

– STM32CubeMX, a graphical software configuration tool that allows the automatic 
generation of C initialization code using graphical wizards

– STM32CubeIDE, an all-in-one development tool with peripheral configuration, 
code generation, code compilation, and debug features

– STM32CubeProgrammer (STM32CubeProg), a programming tool available in 
graphical and command-line versions

– STM32CubeMonitor (STM32CubeMonitor, STM32CubeMonPwr, 
STM32CubeMonRF, STM32CubeMonUCPD) powerful monitoring tools to fine-
tune the behavior and performance of STM32 applications in real-time

• STM32Cube MCU and MPU Packages, comprehensive embedded-software platforms 
specific to each microcontroller and microprocessor series (such as STM32CubeL4 for 
the STM32L4 Series and STM32L4+ Series), which include:

– STM32Cube hardware abstraction layer (HAL), ensuring maximized portability 
across the STM32 portfolio

– STM32Cube low-layer APIs, ensuring the best performance and footprints with a 
high degree of user control over hardware

– A consistent set of middleware components such as FAT file system, RTOS, USB 
Host and Device, Touch library, and Graphics

– All embedded software utilities with full sets of peripheral and applicative 
examples

• STM32Cube Expansion Packages, which contain embedded software components 
that complement the functionalities of the STM32Cube MCU and MPU Packages with:

– Middleware extensions and applicative layers

– Examples running on some specific STMicroelectronics development boards

This user manual describes how to get started with the STM32CubeL4 MCU Package.

Section 1 describes the main features of the STM32CubeL4 MCU Package, part of the 
STM32Cube initiative. Section 2 and Section 3 provide an overview of the STM32CubeL4 
architecture and MCU Package structure.
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1 STM32CubeL4 main features

The STM32CubeL4 MCU Package runs on STM32 microcontrollers based on the Arm®(a) 

Cortex®-M4 processor.

STM32CubeL4 gathers, in a single package, all the generic embedded software 
components required to develop an application on STM32L4 and STM32L4+ MCUs. In line 
with the STM32Cube initiative, this set of components is highly portable, not only within the 
STM32L4 Series or STM32L4+ Series but also to other STM32 series.

STM32CubeL4 is fully compatible with STM32CubeMX code generator that allows the 
generation of initialization code. The package includes low-layer (LL) and hardware 
abstraction layer (HAL) APIs that cover the microcontroller hardware, together with an 
extensive set of examples running on STMicroelectronics boards. The HAL and LL APIs are 
available in open-source BSD license for user convenience.

The STM32CubeL4 MCU Package also contains a set of middleware components with the 
corresponding examples. They come in free user-friendly license terms:

• Full USB Host and Device stack supporting many classes.

– Host Classes: HID, MSC, CDC, Audio and MTP

– Device Classes: HID, MSC, CDC, Audio, DFU, LPM and BCD

• STemWin, a professional graphical stack solution available in binary format and based 
on STMicroelectronics partner solution SEGGER emWin 

• CMSIS-RTOS implementation with FreeRTOS™ open source solution

• FAT file system based on open source FatFS solution

• STMTouch touch sensing library solution.

Several applications and demonstrations implementing all these middleware components 
are also provided in the STM32CubeL4 MCU Package.

Figure 1. STM32CubeL4 firmware components

a. Arm is a registered trademark of Arm Limited (or its subsidiaries) in the US and or elsewhere.
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2 STM32CubeL4 architecture overview

The STM32Cube firmware solution is built around three independent levels that interact 
easily as described in Figure 2. 

Figure 2. STM32CubeL4 firmware architecture
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2.1.1 Board support package (BSP)

This layer offers a set of APIs corresponding to the hardware components of a board (that is 
LCD, Audio, microSD™ and MEMS drivers). It is composed of two parts:

• Component

This is the driver associated to the external device on the board and not to the STM32. 
The component driver provides specific APIs to the BSP driver external components 
and is portable on any other board.

• BSP driver

It allows to link the component driver to a specific board and provides a set of user-
friendly APIs. The API naming rule is BSP_FUNCT_Action().

Example: BSP_LED_Init(), BSP_LED_On()

The BSP is based on a modular architecture allowing easy porting to any hardware by just 
implementing the low-level routines.

2.1.2 Hardware abstraction layer (HAL) and low-layer (LL)

The STM32CubeL4 HAL and LL are complementary and cover a wide range of applications 
requirements:

• The HAL drivers offer high-level function-oriented highly-portable APIs. They hide the 
MCU and peripheral complexity to end user.

The HAL drivers provide generic multi-instance feature-oriented APIs which simplify 
user application implementation by providing ready-to-use processes. As an example, 
for the communication peripherals (such as I2S or UART), the HAL drivers provide 
APIs allowing the initialization and configuration of the peripheral, the management of 
data transfer based on polling, the interrupt or DMA process, and the handling of 
communication errors that may raise. The HAL driver APIs are split in two categories:

– Generic APIs providing common and generic functions to all the STM32 Series

– Extension APIs providing specific and customized functions for a specific family or 
a specific part number.

• The low-layer APIs provide low-level APIs at register level, with better optimization but 
less portability. They require a deep knowledge of MCU and peripheral specifications.

The LL drivers are designed to offer a fast light-weight expert-oriented layer which is 
closer to the hardware than the HAL. Contrary to the HAL, LL APIs are not provided for 
peripherals where optimized access is not a key feature, or for those requiring heavy 
software configuration and/or complex upper-level stack (such as FSMC, USB, or 
SDMMC).

The LL drivers feature:

– A set of functions to initialize peripheral main features according to the parameters 
specified in data structures

– A set of functions used to fill initialization data structures with the reset values 
corresponding to each field

– Function for peripheral de-initialization (peripheral registers restored to their 
default values)

– A set of inline functions for direct and atomic register access

– Full independence from HAL and capability to be used in standalone mode 
(without HAL drivers) 

– Full coverage of the supported peripheral features.
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2.1.3 Basic peripheral usage examples

This layer includes the examples built over the STM32 peripherals. These examples use 
either the HAL or the low-layer drivers APIs or both. They use the BSP resources as well.

2.2 Level 1

This level is divided into two sub-layers: 

• Middleware components

• Examples based on the middleware components

2.2.1 Middleware components

The middleware is a set of libraries covering USB Host and Device Libraries, STMTouch 
touch sensing, STemWin, FreeRTOS™ and FatFS. Horizontal interactions between the 
components of this layer are done directly by calling the corresponding API, while the 
vertical interaction with the low-level drivers is done through specific callbacks and static 
macros implemented in the library system call interface. For example, the FatFS 
implements the disk I/O driver to access a microSD™ drive or provides an implementation 
of a USB Mass Storage Class.
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The main features of each middleware component are:

• USB Host and Device libraries

– Several USB classes supported (Mass-Storage, HID, CDC, DFU, LPM and BCD).

– Support of multi-packet transfer features that allows large amounts of data to be 
sent without splitting them into maximum packet size transfers.

– Use of configuration files to change the core and the library configuration without  
changing the library code (Read Only).

– 32-bit aligned data structures to handle DMA-based transfer in high-speed modes.

– Support of multi USB OTG core instances from user level through configuration 
file. This allows the execution of operations with more than one USB host/device 
peripheral.

– RTOS and standalone operation.

– Link with low-level driver through an abstraction layer using the configuration file 
to avoid any dependency between the library and the low-level drivers.

• STemWin Graphical stack

– Professional grade solution for GUI development based on SEGGER emWin 
solution.

– Optimized display drivers.

– Software tools for code generation and bitmap editing (for instance STemWin 
Builder).

• FreeRTOS™

– Open source standard.

– CMSIS compatibility layer.

– Tickless operation during low-power mode.

– Integration with all STM32Cube middleware modules.

• FAT File system

– FATFS FAT open source library.

– Long file name support.

– Dynamic multi-drive support.

– RTOS and standalone operation.

– Examples with microSD™.

• STM32 Touch sensing library

Robust STMTouch capacitive touch sensing solution supporting proximity, touchkey, 
linear and rotary touch sensors. It is based a proven surface charge transfer acquisition 
principle.
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2.2.2 Examples based on the middleware components

Each middleware component comes with one or more examples (also called Applications) 
showing how to use it. Integration examples that use several middleware components are 
provided as well. 

2.3 Level 2

This level is composed of a single layer which consist in a global real-time and graphical 
demonstration based on the middleware service layer, the low-level abstraction layer and 
the basic peripheral usage applications for board based features.
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3 STM32CubeL4 MCU Package overview

3.1 Supported STM32L4 Series and STM32L4+ Series 
microcontrollers and hardware

STM32Cube offers highly portable hardware abstraction layer (HAL) built around a generic 
architecture. It allows the built-upon layers, such as the middleware layer, to implement their 
functions without knowing, in-depth, the MCU used. This improves the library code re-
usability and guarantees an easy portability on other devices.

In addition, thanks to its layered architecture, the STM32CubeL4 offers full support of all 
STM32L4 Series and STM32L4+ Series. The user has only to define the right macro in 
stm32l4xx.h.

Table 1 and Table 2 show the macro to be defined depending on the STM32L4 Series or 
STM32L4+ Series microcontroller used respectively. This macro must also be defined in the 
compiler preprocessor.

          

Table 1. Macros for STM32L4 Series 

Macro defined in 
stm32l4xx.h

STM32L4 Series devices

STM32L412xx
STM32L412CB, STM32L412KB, STM32L412RB, STM32L412TB,

STM32L412C8, STM32L412K8, STM32L412R8, STM32L412T8

STM32L422xx STM32L422CB, STM32L422KB, STM32L422RB, STM32L422TB

STM32L431xx
STM32L431CC, STM32L431KC, STM32L431RC, STM32L431VC, 
STM32L431CB, STM32L431KB, STM32L431RB

STM32L432xx STM32L432KC, STM32L432KB 

STM32L433xx
STM32L433CC, STM32L433RC, STM32L433VC, STM32L433CB, 
STM32L433RB

STM32L442xx STM32L442KC

STM32L443xx STM32L443CC, STM32L443RC, STM32L443VC

STM32L451xx
STM32L451CC, STM32L451RC, STM32L451VC, STM32L451CE, 
STM32L451RE, STM32L451VE

STM32L452xx
STM32L452CC, STM32L452RC, STM32L452VC, STM32L452CE, 
STM32L452RE, STM32L452VE

STM32L462xx STM32L462CE, STM32L462RE, STM32L462VE

STM32L471xx
STM32L471RG, STM32L471JG, STM32L471VG, STM32L471QG, 
STM32L471ZG, STM32L471RE, STM32L471JE, STM32L471VE, 
STM32L471QE, STM32L471ZE

STM32L475xx
STM32L475RG, STM32L475JG, STM32L475VG, STM32L475QG, 
STM32L475ZG, STM32L475RE, STM32L475JE, STM32L475VE, 
STM32L475QE, STM32L475ZE, STM32L475RC, STM32L475VC

STM32L476xx
STM32L476RG, STM32L476JG, STM32L476VG, STM32L476QG, 
STM32L476ZG, STM32L476RE, STM32L476JE, STM32L476VE, 
STM32L476QE, STM32L476ZE, STM32L476RC, STM32L476VC

STM32L485xx  STM32L485JC, STM32L485JE
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STM32CubeL4 features a rich set of examples and applications that facilitate the use of the 
HAL drivers and middleware components. These examples run on the STMicroelectronics 
boards listed in Table 3 and in Table 4.

          

STM32L486xx
STM32L486RG, STM32L486JG, STM32L486VG, STM32L486QG, 
STM32L486ZG

STM32L496xx
STM32L496RG, STM32L496VG, STM32L496QG, STM32L496ZG, 
STM32L496AG

STM32L4A6xx
STM32L4A6RG, STM32L4A6VG, STM32L4A6QG, STM32L4A6ZG, 
STM32L4A6AG

Table 2. Macros for STM32L4+ Series 

Macro defined in 
stm32l4xx.h

STM32L4+ Series devices

STM32L4P5xx
STM32L4P5CG, STM32L4P5RG, STM32L4P5VG, STM32L4P5QG, 
STM32L4P5ZG, STM32L4P5AG, STM32L4P5CE, STM32L4P5RE, 
STM32L4P5VE, STM32L4P5QE, STM32L4P5ZE, STM32L4P5AE

STM32L4Q5xx
STM32L4Q5CG, STM32L4Q5RG, STM32L4Q5VG, STM32L4Q5QG, 
STM32L4Q5ZG, STM32L4Q5AG

STM32L4R5xx
STM32L4R5VI, STM32L4R5QI, STM32L4R5ZI, STM32L4R5AI, 
STM32L4R5VG, STM32L4R5QG, STM32L4R5ZG, STM32L4R5AG

STM32L4R7xx STM32L4R7VI, STM32L4R7ZI, STM32L4R7AI

STM32L4R9xx
STM32L4R9VI, STM32L4R9ZI, STM32L4R9AI, STM32L4R9VG, 
STM32L4R9ZG, STM32L4R9AG

STM32L4S5xx STM32L4S5VI, STM32L4S5QI, STM32L4S5ZI, STM32L4S5AI

STM32L4S7xx STM32L4S7VI, STM32L4S7ZI, STM32L4S7AI

STM32L4S9xx STM32L4S9VI, STM32L4S9ZI, STM32L4S9AI

Table 3. Boards for STM32L4 Series 

Board STM32L4 Series devices supported

STM32L476G-EVAL STM32L476xx

32L476GDISCOVERY STM32L476xx

NUCLEO-L476RG STM32L476xx

NUCLEO-L412KB STM32L412xx

NUCLEO-L412RB-P STM32L412xx

NUCLEO-L432KC STM32L432xx

NUCLEO-L433RC-P STM32L433xx

NUCLEO-L452RE STM32L452xx

NUCLEO-L452RE-P STM32L452xx

NUCLEO-L496ZG  STM32L496xx

Table 1. Macros for STM32L4 Series (continued)
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STM32CubeL4 supports Nucleo-32, Nucleo-64 and Nucleo-144 boards: 

• Nucleo-64 and Nucleo-144 boards are compatible with Adafruit LCD display 
ARDUINO® Uno shields, which embed a microSD™ connector and a joystick in 
addition to the LCD. 

• Nucleo-32 boards compatible with Gravitech 7-segment display ARDUINO® Nano 
shields, which allow numbers or characters up to four digits to be displayed. 

The ARDUINO® shield drivers are provided within the BSP component. Their usage is 
illustrated by a demonstration included in the MCU Package.

The STM32CubeL4 firmware is able to run on any compatible hardware as long as the user 
updates the BSP drivers to port the provided examples. 

NUCLEO-L496ZG-P STM32L496xx

32L496GDISCOVERY STM32L496xx

B-L475E-IOT01A  STM32L475xx

Table 4. Boards for STM32L4+ Series 

Board STM32L4+ Series devices supported

NUCLEO-L4P5ZG STM32L4P5xx

32L4P5GDISCOVERY STM32L4P5xx

STM32L4R9I-EVAL STM32L4R9xx

32L4R9IDISCOVERY STM32L4R9xx

NUCLEO-L4R5ZI STM32L4R5xx

NUCLEO-L4R5ZI-P STM32L4R5xx

B-L4S5I-IOT01A STM32L4S5xx

Table 3. Boards for STM32L4 Series (continued)
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3.2 MCU Package overview

The STM32CubeL4 firmware solution is provided in one single zip package having the 
structure shown in Figure 3.

Figure 3. STM32CubeL4 MCU Package structure

1. The library files in brown must not be modified by the user, while the files in blue can be modified.
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For each board, a set of examples is provided with pre-configured projects for EWARM, 
MDK-ARM and SW4STM32, except for the 32L4P5GDISCOVERY, NUCLEO-L4P5ZG and 
B-L4S5I-IOT01A boards where SW4STM32 is replaced by STM32CubeIDE.

Figure 4 shows the projects structure for the NUCLEO-L476RG board.

Figure 4. STM32CubeL4 examples overview

The examples are classified depending on the STM32Cube level to which they apply, and 
are named as explained below: 

• Level 0 examples are called Examples, Examples_LL and Examples_MIX. They use 
respectively HAL drivers, LL drivers and a mix of HAL and LL drivers without any 
middleware component.

• Level 1 examples are called Applications. They provide typical use cases of each 
middleware component.
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The template projects available in the Templates and Templates_LL  directories allow the 
quick build of any firmware application on a given board.

 All examples have the same structure:

• \Inc folder that contains all header files.

• \Src folder for the sources code.

• \EWARM, \MDK-ARM, \SW4STM32 and \STM32CubeIDE folders contain the pre-
configured project for each toolchain.

• readme.txt describing the example behavior and environment needed to make it work.

Table 5 gives the number of projects available for each board.
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Table 5. Number of examples available for each board  
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Total

Templates_LL 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 20

Templates 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 20

Examples_MIX 0 0 0 0 1 0 10 12 0 0 0 0 2 2 0 0 0 0 2 0 29

Examples_LL 0 0 0 0 10 0 94 91 0 0 0 0 15 7 0 0 0 1 1 0 219

Examples 51 87 3 52 55 3 97 71 3 82 3 62 43 20 0 1 17 26 23 17 718

Demonstrations 1 1 0 1 0 0 1 1 0 1 0 1 1 1 0 1 1 1 1 1 14

Applications 12 27 0 5 0 0 10 2 0 15 0 5 15 1 3 11 6 2 11 5 130

Total 66 117 5 60 68 5 214 179 5 100 5 70 78 33 5 15 26 32 40 25 1148
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4 Getting started with STM32CubeL4

4.1 Running the first example

This section explains how simple is to run a first example within STM32CubeL4. It uses as 
an illustration the generation of a simple LED toggle running on a NUCLEO-L476RG board:

1. Download the STM32CubeL4 MCU Package. Unzip it into a directory. Make sure not to 
modify the package structure shown in Figure 3. Note that it is also recommended to 
copy the package at a location close to the root volume (e.g. C\Eval or G:\Tests) to 
avoid some IDEs encounter problems when the path length is too long.

2. Browse to \Projects\NUCLEO-L476RG\Examples.

3. Open \GPIO, then \GPIO_EXTI folder.

4. Open the project with the preferred toolchain. A quick overview on how to open, build 
and run an example with the supported toolchains is given below.

5. Rebuild all files and load the image into target memory.

6. Run the example: each time the USER pushbutton is pressed, the LED2 toggles (for 
more details, refer to the example readme file).
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To open, build and run an example with the supported toolchains follow the steps below:

• EWARM

a) Under the example folder, open \EWARM sub-folder.

b) Launch the Project.eww workspace(a).

c) Rebuild all files: Project->Rebuild all.

d) Load project image: Project->Debug.

e) Run program: Debug->Go(F5).

• MDK-ARM

a) Under the example folder, open \MDK-ARM sub-folder.

b) Launch the Project.uvprojx workspace(a).

c) Rebuild all files: Project->Rebuild all target files.

d) Load project image: Debug->Start/Stop Debug Session.

e) Run program: Debug->Run (F5).

• SW4STM32

a) Open the SW4STM32 toolchain

b) Click File->Switch Workspace->Other and browse to the SW4STM32 
workspace directory

c) Click File->Import, select General->Existing Projects into Workspace and then 
click Next.

d) Browse to the SW4STM32 workspace directory and select the project.

e) Rebuild all project files: select the project in the Project explorer window then 
click the Project->build project menu.

f) Run program: Run->Debug (F11)

• STM32CubeIDE

a) Open the STM32CubeIDE toolchain.

b) Click File->Switch Workspace->Other and browse to STM32CubeIDE 
workspace directory.

c) Click File->Import, select General->Existing Projects into Workspace and then 
click Next.

d) Browse to the STM32CubeIDE workspace directory, select the project.

e) Rebuild all project files: select the project in the Project explorer window then 
click the Project->build project menu.

f) Run program: Run->Debug (F11).

a. The workspace name may change from one example to another.
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4.2 Developing user application 

4.2.1 HAL application

This section describes the steps required to create user HAL application with 
STM32CubeL4:

1. Create the project

To create a new project, the user can either start from the Template project provided for 
each board under \Projects\<STM32xxx_yyy>\Templates or from any available project 
under \Projects\<STM32xxy_yyy>\Examples or \Projects\<STM32xx_yyy>\Applications 
(where <STM32xxx_yyy> refers to the board name, e.g. STM32L476G-EVAL).

The Template project provides an empty main loop function.As a starting point it is 
recommended to get familiar with the project settings for STM32CubeL4.  
The template main characteristics are the following: 

– It contains the source code of HAL, CMSIS and BSP drivers, that are the minimal 
components required to develop a code on a given board.

– It contains the include paths for all the firmware components.

– It selects the supported STM32L4 Series or STM32L4+ Series device and allows 
the configuration of CMSIS and HAL drivers accordingly.

– It provides ready-to-use user files that are pre-configured as follows:

HAL initialized with default time base with ARM Core SysTick.

SysTick ISR implemented for HAL_Delay() purpose.

Note: When copying an existing project to another location, make sure to update the include 
paths.

2. Add the necessary middleware to the project (optional)

The available middleware stacks are: USB Host and Device library, STMTouch touch 
sensing, STemWin, FreeRTOS™ and FatFS. To know which source files and include 
paths to add in the project-file list, refer to the documentation provided for each 
middleware or look at the applications available under: 
\Projects\STM32xxx_yyy\Applications\<MW_Stack> (where <MW_Stack> refers to the 
middleware stack, e.g. USB_Device).

3. Configure the firmware components

The HAL and middleware components offer a set of build time configuration options 
using macros # define declared in a header file. A template configuration file is 
provided within each component, it has to be copied to the project folder (usually the 
configuration file is named xxx_conf_template.h, the word ‘_template’ needs to be 
removed when copying it to the project folder). The configuration file provides enough 
information to know the impact of each configuration option. More detailed information 
is available in the documentation provided for each component.

4. Start the HAL library

After jumping to the main program, the application code must call HAL_Init() API to 
initialize the HAL library that executes the following tasks:

a) Configuration of the Flash prefetch and SysTick interrupt priority (through macros 
defined in stm32l4xx_hal_conf.h).

b) Configuration of the SysTick to generate an interrupt each 1 ms at the SysTick 
interrupt priority TICK_INT_PRIO defined in stm32l4xx_hal_conf.h that is clocked 
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by the MSI (at this stage, the clock is not yet configured and thus the system is 
running from the internal 4 MHz MSI).

c) Setting of NVIC Group Priority to 4.

d) Call of HAL_MspInit() callback function defined in stm32l4xx_hal_msp.c user file 
to perform global low-level hardware initializations.

5. Configure the system clock

The system clock configuration is done by calling the two APIs described below:

a) HAL_RCC_OscConfig(): this API configures the internal and/or external 
oscillators, as well as the PLL source and factors. The user chooses to configure 
one oscillator or all oscillators. The PLL configuration can be skipped if there is no 
need to run the system at high frequency.

b) HAL_RCC_ClockConfig(): this API configures the system clock source, the Flash 
memory latency and AHB and APB prescalers.

6. Initialize the peripheral

a) First write the peripheral HAL_PPP_MspInit function. Proceed as follows:

– Enable the peripheral clock.

– Configure the peripheral GPIOs.

– Configure DMA channel and enable DMA interrupt (if needed).

– Enable peripheral interrupt (if needed).

b) Edit the stm32xxx_it.c to call the required interrupt handlers (peripheral and DMA), 
if needed.

c) Write process complete callback functions if peripheral interrupt or DMA is used.

d) In the main.c file, initialize the peripheral handle structure then call the function 
HAL_PPP_Init() to initialize the peripheral.

7. Develop the application

At this stage, the system is ready and the user can start developing the application 
code. 

– The HAL provides intuitive and ready-to-use APIs to configure the peripheral. It 
supports polling, interrupts and DMA programming model, to accommodate any 
application requirements. For more details on how to use each peripheral, refer to 
the rich examples set provided in the STM32CubeL4 package.

– If the application has some real-time constraints, the user finds a large set of 
examples showing how to use FreeRTOS™ and how integrate it with all 
middleware stacks provided within STM32CubeL4. This is a good starting point to 
develop the application.

Caution: In the default HAL implementation, SysTick timer is used as timebase: it generates 
interrupts at regular time intervals. If HAL_Delay() is called from peripheral ISR process, 
make sure that the SysTick interrupt has higher priority (numerically lower) than the 
peripheral interrupt. Otherwise, the caller ISR process will be blocked. Functions affecting 
timebase configurations are declared as __weak to make override possible in case of other 
implementations in user file (using a general purpose timer for example or other time 
source). For more details, refer to HAL_TimeBase example.
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4.2.2 LL application

This section describes the steps needed to create a LL application using STM32CubeL4.

1. Create the project

To create a new project, the user can either start from the Templates_LL project 
provided for each board under \Projects\<STM32xxx_yyy>\Templates_LL or from any 
available project under \Projects\<STM32xxy_yyy>\Examples_LL (<STM32xxx_yyy> 
refers to the board name, such as NUCLEO-L476RG).

The Template project provides an empty main loop function, however it is a good 
starting point to get familiar with project settings for STM32CubeL4. 

The template main characteristics are the following: 

– It contains the source code of LL and CMSIS drivers that are the minimal 
components to develop a code on a given board.

– It contains the include paths for all the required firmware components.

– It selects the supported STM32L4 Series or STM32L4+ Series device and allows 
the configuration of CMSIS and LL drivers accordingly.

– It provides ready-to-use user files, that are pre-configured as follows: 

main.h: LED & USER_BUTTON definition abstraction layer

main.c: System clock configuration for maximum frequency. 

2. Port an existing project to another board

To port an existing project to another target board, start from the Templates_LL project 
provided for each board and available under 
\Projects\<STM32xxx_yyy>\Templates_LL:

a) Select an LL example

To find the board on which LL examples are deployed, refer to the list of LL 
examples in STM32CubeProjectsList.html, to Table 5: Number of examples 
available for each board,  or to application note “STM32Cube firmware examples 
for STM32L4 Series and STM32L4+ Series” (AN4726).

b) Port the LL example

– Copy/paste the Templates_LL folder to keep the initial source or directly update 
the existing Templates_LL project. 

– Then LL example porting consists mainly of replacing Templates_LL files by the 
Examples_LL targeted project. 

– Keep all board specific parts. For reasons of clarity, board specific parts have been 
flagged with specific tags:

/* =========== BOARD SPECIFIC CONFIGURATION CODE BEGIN =========== */

/* ============ BOARD SPECIFIC CONFIGURATION CODE END ============= */ 

Thus the main porting steps are the following:

– Replace stm32l4xx_it.h file

– Replace stm32l4xx_it.c file 

– Replace main.h file and update it: keep the LED and user button definition of the 
LL template under "BOARD SPECIFIC CONFIGURATION" tags.



Getting started with STM32CubeL4 UM1860

24/31 UM1860 Rev 14

– Replace main.c file, and update it: 

Keep the clock configuration of the SystemClock_Config() LL template: function 
under "BOARD SPECIFIC CONFIGURATION" tags.

Depending on the LED definition, replace all LEDx occurrences with another LEDy 
available in main.h.

Thanks to these adaptations, the example should be functional on the targeted 
board.

4.3 Using STM32CubeMX to generate initialization C code 

An alternative to steps 1 to 6 described in Section 4.2 consists of using the STM32CubeMX 
 tool to generate code to initialize the system, peripherals and middleware  (steps 1 to 6 
above) through a step-by-step process:

1. Select the STMicroelectronics STM32 microcontroller that matches the required set of 
peripherals.

2. Configure each required embedded software thanks to a pinout-conflict solver, a clock-
tree setting helper, a power consumption calculator, and the utility performing MCU 
peripheral configuration (e.g. GPIO or USART) and middleware stacks (e.g. USB).

3. Generate the initialization C code based on the configuration selected. This code is  
ready-to-use within several development environments. The user code is kept at the  
next code generation.

For more information, please refer to STM32CubeMX user manual (UM1718).

4.4 Getting STM32CubeL4 release updates

The STM32CubeL4 MCU Package new releases and patches are available from 
www.st.com/stm32l4. They may be also retrieved using the "CHECK FOR UPDATE" button 
in STM32CubeMX. For more details, refer to the section 3 of STM32CubeMX user manual 
(UM1718).

4.5 STM32 Nucleo Power GUI tool

The STM32CubeL4 MCU Package comes with a Windows® graphical user interface (GUI) 
tool available under Utilities\PC_Software folder. This tool allows connection via the USB 
ST-Link virtual COM port, to any STM32 Nucleo hardware boards supported by the MCU 
Package. It allows the selection of various low-power modes and benchmarking codes 
thanks to the available binary files. Users therefore quickly assess STM32L4 Series and 
STM32L4+ Series low-power performance.
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5 FAQ

5.1 What is the license scheme for the STM32CubeL4 firmware?

The HAL is distributed under a non-restrictive BSD (Berkeley Software Distribution) license.

The middleware stacks made by STMicroelectronics (USB Host and Device Libraries, 
STemWin) come with a licensing model allowing easy reuse, provided it runs on an 
STMicroelectronics device.

The middleware layer based on well-known open-source solutions (FreeRTOS™ and 
FatFS) has user-friendly license terms. For more details, refer to the license agreement of 
each middleware.

5.2 Which boards are supported by the STM32CubeL4 MCU 
Package?

The STM32CubeL4 MCU Package provides BSP drivers and ready-to-use examples for the 
following STM32L4 Series and STM32L4+ Series boards: STM32L476G-EVAL, 
32L476GDISCOVERY, NUCLEO-L476RG, NUCLEO-L412KB, NUCLEO-L412RB-P, 
NUCLEO-L432KC, 32L496GDISCOVERY, NUCLEO-L496ZG, NUCLEO-L496ZG-P,  
B-L475E-IOT01A, NUCLEO-L433RC-P, NUCLEO-L452RE, NUCLEO-L452RE-P,  
NUCLEO-L4R5ZI, NUCLEO-L4R5ZI-P, STM32L4R9I-EVAL, 32L4R9IDISCOVERY, 
32L4P5GDISCOVERY, NUCLEO-L4P5ZG and B-L4S5I-IOT01A.

5.3 Are there any examples provided with the ready-to-use 
toolset projects?

Yes, there are. STM32CubeL4 provides a rich set of examples and applications. They come 
with the pre-configured projects for IAR Embedded Workbench®, Keil® and GCC toolchains.

5.4 Is there any link with Standard Peripheral Libraries?

The STM32Cube HAL and LL drivers replace the standard peripheral library: 

• The HAL drivers offer a higher abstraction level compared to the standard peripheral 
APIs. They focus on peripheral common features rather than on hardware. Their higher 
abstraction level allows the definition of a set of user-friendly APIs that can be easily 
ported from one product to another.

• The LL drivers offer low-level APIs at registers level. They are organized in a simpler 
and clearer way than the direct register accesses. LL drivers also include peripheral 
initialization APIs, which are more optimized compared to what is offered by the SPL, 
while being functionally similar. Compared to HAL drivers, these LL initialization APIs 
allow an easier migration from the SPL to the STM32Cube LL drivers, since each SPL 
API has its equivalent LL API(s).
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5.5 Do the HAL drivers take benefit from interrupts or DMA? 
How can this be controlled?

Yes, they do. The HAL layer supports three API programming models: polling, interrupt and 
DMA (with or without interrupt generation). 

5.6 How are the product/peripheral specific features managed?

The HAL drivers offer extended APIs; that is, specific functions as add-ons to the common 
API, to support features available on some products/lines only.

5.7 How can STM32CubeMX generate code based on embedded 
software?

STM32CubeMX has a built-in knowledge of STM32 microcontrollers, including their 
peripherals and software that provides a graphical representation to the user and generates 
*.h/*.c files based on the user configuration.

5.8 How can I get regular updates on the latest STM32CubeL4 
firmware releases?

Refer to Section 4.4.

5.9 When should I use HAL instead of LL drivers?

HAL drivers offer high-level and function-oriented APIs, with a high level of portability. 
Product/IPs complexity is hidden for end users.

LL drivers offer low-level APIs at register level, with a better optimization but less portability. 
They require a deep knowledge of product/IPs specifications.

5.10 How can I include LL drivers in my environment?  
Is there any LL configuration file as for HAL?

There is no configuration file. Source code shall directly include the necessary 
stm32l4xx_ll_ppp.h file(s).

5.11 Can I use HAL and LL drivers together? If yes, what are the 
constraints?

It is possible to use both HAL and LL drivers. One handles the IP initialization phase with 
HAL and then manage the I/O operations with LL drivers.

The major difference between HAL and LL is that HAL drivers require to create and use 
handles for operation management while, LL drivers operates directly on peripheral 
registers. Mixing HAL and LL is illustrated in Examples_MIX example.
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5.12 Are there any LL APIs not available with HAL?

Yes, there are.

A few Cortex® APIs have been added in stm32l4xx_ll_cortex.h, for example to access SCB 
or SysTick registers.

5.13 Why are SysTick interrupts not enabled on LL drivers?

Because when using LL drivers in standalone mode, there is no need to enable SysTick 
interrupts since they are not used in LL APIs, while HAL functions requires SysTick 
interrupts to manage timeouts.

5.14 How are LL initialization APIs enabled?

The definition of LL initialization APIs and associated resources (structure, literals and 
prototypes) is conditioned by the USE_FULL_LL_DRIVER compilation switch.

To be able to use LL APIs, add this switch in the toolchain compiler preprocessor.
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